re = /[a-zA-Z\u00C0-\u024F\u1E00-\u1EFF]/m
str = 'Ràhūl
Vērmá
Âsmítä
Vêrmã
Süshîlå
Vërmā
Prèmchænd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end