using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z\u00C0-\u024F\u1E00-\u1EFF]";
string input = @"Ràhūl
Vērmá
Âsmítä
Vêrmã
Süshîlå
Vërmā
Prèmchænd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}