import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z\\u00C0-\\u024F\\u1E00-\\u1EFF]";
final String string = "Ràhūl\n"
+ "Vērmá\n"
+ "Âsmítä\n"
+ "Vêrmã\n"
+ "Süshîlå\n"
+ "Vërmā\n"
+ "Prèmchænd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}