re = /\s*src\s*:\s*"(.*?)"/m
str = '<script type=\'text/javascript\'>var holaplayer;
window.hola_player({ player: \'#hola\',
share: false,
poster: \'https://s475.clipwatching.com/i/02/02889/onou5kiza8cr.jpg\',
sources: [{src: "https://s475.clipwatching.com/zx5x4sn47f2txcne4zqsjghf2y3o4r2okiasq6h2zzssd7xctj7bkkn3p7mq/v.mp4", type: "video/mp4", res: 360, label: "360"}],
preload: \'auto\',
thumbnails:{ vtt:\'https://clipwatching.com/dl?op=get_slides&length=1440&url=https://s475.clipwatching.com/i/02/02889/onou5kiza8cr0000.jpg\' },ads: { adTagUrl: \'https://www.movcpm.com/watch.xml?key=383cac3ff2358ef864279f1c5e1053ba\' },
videojs_options: {
html5: {
hlsjsConfig: {
debug: false,
startLevel: 1,
maxBufferLength: 30,
maxBufferSize: 10*1024*1024,
maxMaxBufferLength: 600,
capLevelToPlayerSize: true,
}
},
},
}, function(player){'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end