import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*src\\s*:\\s*\"(.*?)\"";
final String string = "<script type='text/javascript'>var holaplayer;\n"
+ "window.hola_player({ player: '#hola',\n"
+ " share: false,\n"
+ " poster: 'https://s475.clipwatching.com/i/02/02889/onou5kiza8cr.jpg',\n"
+ " sources: [{src: \"https://s475.clipwatching.com/zx5x4sn47f2txcne4zqsjghf2y3o4r2okiasq6h2zzssd7xctj7bkkn3p7mq/v.mp4\", type: \"video/mp4\", res: 360, label: \"360\"}],\n"
+ " preload: 'auto',\n"
+ " thumbnails:{ vtt:'https://clipwatching.com/dl?op=get_slides&length=1440&url=https://s475.clipwatching.com/i/02/02889/onou5kiza8cr0000.jpg' },ads: { adTagUrl: 'https://www.movcpm.com/watch.xml?key=383cac3ff2358ef864279f1c5e1053ba' },\n"
+ " videojs_options: { \n"
+ " html5: {\n"
+ " hlsjsConfig: {\n"
+ " debug: false, \n"
+ " startLevel: 1,\n"
+ " maxBufferLength: 30, \n"
+ " maxBufferSize: 10*1024*1024, \n"
+ " maxMaxBufferLength: 600, \n"
+ " capLevelToPlayerSize: true,\n"
+ " }\n"
+ " },\n"
+ " \n"
+ " },\n"
+ "}, function(player){";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}