# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*src\s*:\s*\"(.*?)\""
test_str = ("<script type='text/javascript'>var holaplayer;\n"
"window.hola_player({ player: '#hola',\n"
" share: false,\n"
" poster: 'https://s475.clipwatching.com/i/02/02889/onou5kiza8cr.jpg',\n"
" sources: [{src: \"https://s475.clipwatching.com/zx5x4sn47f2txcne4zqsjghf2y3o4r2okiasq6h2zzssd7xctj7bkkn3p7mq/v.mp4\", type: \"video/mp4\", res: 360, label: \"360\"}],\n"
" preload: 'auto',\n"
" thumbnails:{ vtt:'https://clipwatching.com/dl?op=get_slides&length=1440&url=https://s475.clipwatching.com/i/02/02889/onou5kiza8cr0000.jpg' },ads: { adTagUrl: 'https://www.movcpm.com/watch.xml?key=383cac3ff2358ef864279f1c5e1053ba' },\n"
" videojs_options: { \n"
" html5: {\n"
" hlsjsConfig: {\n"
" debug: false, \n"
" startLevel: 1,\n"
" maxBufferLength: 30, \n"
" maxBufferSize: 10*1024*1024, \n"
" maxMaxBufferLength: 600, \n"
" capLevelToPlayerSize: true,\n"
" }\n"
" },\n"
" \n"
" },\n"
"}, function(player){")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.