#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*src\s*:\s*"(.*?)""
Local $sString = "<script type='text/javascript'>var holaplayer;" & @CRLF & _
"window.hola_player({ player: '#hola'," & @CRLF & _
" share: false," & @CRLF & _
" poster: 'https://s475.clipwatching.com/i/02/02889/onou5kiza8cr.jpg'," & @CRLF & _
" sources: [{src: "https://s475.clipwatching.com/zx5x4sn47f2txcne4zqsjghf2y3o4r2okiasq6h2zzssd7xctj7bkkn3p7mq/v.mp4", type: "video/mp4", res: 360, label: "360"}]," & @CRLF & _
" preload: 'auto'," & @CRLF & _
" thumbnails:{ vtt:'https://clipwatching.com/dl?op=get_slides&length=1440&url=https://s475.clipwatching.com/i/02/02889/onou5kiza8cr0000.jpg' },ads: { adTagUrl: 'https://www.movcpm.com/watch.xml?key=383cac3ff2358ef864279f1c5e1053ba' }," & @CRLF & _
" videojs_options: { " & @CRLF & _
" html5: {" & @CRLF & _
" hlsjsConfig: {" & @CRLF & _
" debug: false, " & @CRLF & _
" startLevel: 1," & @CRLF & _
" maxBufferLength: 30, " & @CRLF & _
" maxBufferSize: 10*1024*1024, " & @CRLF & _
" maxMaxBufferLength: 600, " & @CRLF & _
" capLevelToPlayerSize: true," & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" " & @CRLF & _
" }," & @CRLF & _
"}, function(player){"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")