// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+\s").unwrap();
let string = "0 Ackman, R.G.. Tocher, C.S. and McLachlan. J.. 1968. Marine phytoplankter fatty acids. J. Fish. Res. Board Can., 25: 1603-1620. 1";
let substitution = "''";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}