re = /^\d+\s/m
str = '0 Ackman, R.G.. Tocher, C.S. and McLachlan. J.. 1968. Marine phytoplankter fatty acids. J. Fish. Res. Board Can., 25: 1603-1620. 1'
subst = '\'\''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result