use strict;
my $str = '0 Ackman, R.G.. Tocher, C.S. and McLachlan. J.. 1968. Marine phytoplankter fatty acids. J. Fish. Res. Board Can., 25: 1603-1620. 1';
my $regex = qr/^\d+\s/mp;
my $subst = '\'\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";