// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)SELECT [\w\s\(\*\)\,]* FROM ticket_file [\w\s\"\'\`\<\>\=]*"#).unwrap();
let string = "SELECT * FROM ticket_file WHERE 1
SELECT id, name FROM ticket_file WHERE id < 100
SELECT COUNT(*) FROM ticket_file
SELECT MAX(id) FROM ticket_file";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}