using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SELECT [\w\s\(\*\)\,]* FROM ticket_file [\w\s\""\'\`\<\>\=]*";
string input = @"SELECT * FROM ticket_file WHERE 1
SELECT id, name FROM ticket_file WHERE id < 100
SELECT COUNT(*) FROM ticket_file
SELECT MAX(id) FROM ticket_file";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}