#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)SELECT [\w\s\(\*\)\,]* FROM ticket_file [\w\s\"\'\`\<\>\=]*"
Local $sString = "SELECT * FROM ticket_file WHERE 1" & @CRLF & _
"" & @CRLF & _
"SELECT id, name FROM ticket_file WHERE id < 100" & @CRLF & _
"" & @CRLF & _
"SELECT COUNT(*) FROM ticket_file" & @CRLF & _
"" & @CRLF & _
"SELECT MAX(id) FROM ticket_file"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")