import Foundation
let pattern = #"^(\s\w|\s\s)\s{2}(\w{2}\d{2}PRI)((?:\s+\d+)+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Device FT01PRI FT02PRI FT03PRI FV01PRI FV02PRI
F AD01PRI 0 0 0 0 0
R CX01PRI 0 3 0 3 6
O CX02PRI 2 2 1 0 0
M CX03PRI 2 0 1 1 6
DA01PRI 0 0 0 0 0
DA02PRI 6 0 0 0 0
DB01PRI 0 0 0 0 0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)