using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\s\w|\s\s)\s{2}(\w{2}\d{2}PRI)((?:\s+\d+)+)";
string substitution = @"";
string input = @" Device FT01PRI FT02PRI FT03PRI FV01PRI FV02PRI
F AD01PRI 0 0 0 0 0
R CX01PRI 0 3 0 3 6
O CX02PRI 2 2 1 0 0
M CX03PRI 2 0 1 1 6
DA01PRI 0 0 0 0 0
DA02PRI 6 0 0 0 0
DB01PRI 0 0 0 0 0 ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}