$re = '/:([^\s:]+):/i';
$str = ':any-non-whitespace:
:text1:sample2
:@(1@#$@SD: :s:
:nospace::inbetween: :because there are 2 colons in the middle:
:nospace:middle:nospace:
: :
::
:::
::::
::j::
:j:k:
:j:k:l:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);