use strict;
my $str = ':any-non-whitespace:
:text1:sample2
:@(1@#$@SD: :s:
:nospace::inbetween: :because there are 2 colons in the middle:
:nospace:middle:nospace:
: :
::
:::
::::
::j::
:j:k:
:j:k:l:';
my $regex = qr/:([^\s:]+):/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}