import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":([^\\s:]+):";
final String string = ":any-non-whitespace:\n"
+ ":text1:sample2\n"
+ ":@(1@#$@SD: :s:\n"
+ ":nospace::inbetween: :because there are 2 colons in the middle:\n"
+ ":nospace:middle:nospace:\n"
+ ": :\n"
+ "::\n"
+ ":::\n"
+ "::::\n"
+ "::j::\n"
+ ":j:k:\n"
+ ":j:k:l:";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}