#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i):([^\s:]+):"
Local $sString = ":any-non-whitespace:" & @CRLF & _
":text1:sample2" & @CRLF & _
":@(1@#$@SD: :s:" & @CRLF & _
":nospace::inbetween: :because there are 2 colons in the middle:" & @CRLF & _
":nospace:middle:nospace:" & @CRLF & _
": :" & @CRLF & _
"::" & @CRLF & _
":::" & @CRLF & _
"::::" & @CRLF & _
"::j::" & @CRLF & _
":j:k:" & @CRLF & _
":j:k:l:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")