re = /(?:"?([^"]*)"?,){2}/
str = '196778,"df,fdfsdf","4.4","ds-sdads231-33","mmh",1023,1,"20150,62519535TY"'
subst = 'bar'
result = str.sub(re, subst)
# Print the result of the substitution
puts result