package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)(?:"?([^"]*)"?,){2}`)
var str = []byte(`196778,"df,fdfsdf","4.4","ds-sdads231-33","mmh",1023,1,"20150,62519535TY"`)
var substitution = []byte("bar")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}