const regex = /(?:"?([^"]*)"?,){2}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:"?([^"]*)"?,){2}', '')
const str = `196778,"df,fdfsdf","4.4","ds-sdads231-33","mmh",1023,1,"20150,62519535TY"`;
const subst = `bar`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);