# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:"?([^"]*)"?,){2}/bar/U;t' <<< "196778,\"df,fdfsdf\",\"4.4\",\"ds-sdads231-33\",\"mmh\",1023,1,\"20150,62519535TY\""