re = /(?<![-+\/*(\s])((\s*\()?(?:(?:\s*\$Q\w+\s*|\d+\.?\d*\s*)[-+\/*])+(?:\s*\$Q\w+|\d+\.?\d*)\s*(?(2)\)))(\s*[=!><]+\s*)(\d+\.?\d*)/x
str = 'hgfhf ( $Q130A + $Q130B + $Q130C + $Q130D + $Q130E + $Q130F+ $Q130G + $Q130H + $Q130I + $Q130J + $Q130K + $Q130L + $Q130M ) != 100'
# Print the match result
str.match(re) do |match|
puts match.to_s
end