const regex = new RegExp('(?<![-+\\/*(\\s])((\\s*\\()?(?:(?:\\s*\\$Q\\w+\\s*|\\d+\\.?\\d*\\s*)[-+\\/*])+(?:\\s*\\$Q\\w+|\\d+\\.?\\d*)\\s*(?(2)\\)))(\\s*[=!><]+\\s*)(\\d+\\.?\\d*)', '')
const str = `hgfhf ( \$Q130A + \$Q130B + \$Q130C + \$Q130D + \$Q130E + \$Q130F+ \$Q130G + \$Q130H + \$Q130I + \$Q130J + \$Q130K + \$Q130L + \$Q130M ) != 100`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}