import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![-+\\/*(\\s])((\\s*\\()?(?:(?:\\s*\\$Q\\w+\\s*|\\d+\\.?\\d*\\s*)[-+\\/*])+(?:\\s*\\$Q\\w+|\\d+\\.?\\d*)\\s*(?(2)\\)))(\\s*[=!><]+\\s*)(\\d+\\.?\\d*)";
final String string = "hgfhf ( $Q130A + $Q130B + $Q130C + $Q130D + $Q130E + $Q130F+ $Q130G + $Q130H + $Q130I + $Q130J + $Q130K + $Q130L + $Q130M ) != 100";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}