use strict;
my $str = 'arn:aws:iam::389617777922:root';
my $regex = qr/^.*:(\d+):(root|(user\/.*))$/ip;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";