const regex = /^.*:(\d+):(root|(user\/.*))$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*:(\\d+):(root|(user\\\/.*))$', 'i')
const str = `arn:aws:iam::389617777922:root`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);