# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*:(\d+):(root|(user\\/.*))$/$1/i;t' <<< "arn:aws:iam::389617777922:root"