using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*:(\d+):(root|(user\/.*))$";
string substitution = @"$1";
string input = @"arn:aws:iam::389617777922:root";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}