re = /[^{]*({[^}]*})/m
str = '{
"foo":"main",
"baz":1,
"obj":{
"T2":18,
"H2":73,
"T3":20,
"H3":53
},
"bar":"side",
"when":"2000-01-01T00:00:50.500Z"
}...
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end