$re = '/[^{]*({[^}]*})/m';
$str = '{
"foo":"main",
"baz":1,
"obj":{
"T2":18,
"H2":73,
"T3":20,
"H3":53
},
"bar":"side",
"when":"2000-01-01T00:00:50.500Z"
}...
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);