package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^{]*({[^}]*})`)
var str = `{
"foo":"main",
"baz":1,
"obj":{
"T2":18,
"H2":73,
"T3":20,
"H3":53
},
"bar":"side",
"when":"2000-01-01T00:00:50.500Z"
}...
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}