using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^{]*({[^}]*})";
string input = @"{
""foo"":""main"",
""baz"":1,
""obj"":{
""T2"":18,
""H2"":73,
""T3"":20,
""H3"":53
},
""bar"":""side"",
""when"":""2000-01-01T00:00:50.500Z""
}...
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}