import Foundation
let pattern = #"https?:\/\/my\.matterport\.com\/show\/\??(m=(?<code>[\w\d]+))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://my.matterport.com/show/?m=kiVrPJ4GLGF&brand=0&ts=2
https://my.matterport.com/show/?m=8QLBuW5dxqB&brand=0&ts=3&help=1
https://my.matterport.com/show/?m=vycyVs9Xe9W
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)