const regex = /https?:\/\/my\.matterport\.com\/show\/\??(m=(?<code>[\w\d]+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/my\\.matterport\\.com\\\/show\\\/\\??(m=(?<code>[\\w\\d]+))', 'gm')
const str = `https://my.matterport.com/show/?m=kiVrPJ4GLGF&brand=0&ts=2
https://my.matterport.com/show/?m=8QLBuW5dxqB&brand=0&ts=3&help=1
https://my.matterport.com/show/?m=vycyVs9Xe9W`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}