import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/my\\.matterport\\.com\\/show\\/\\??(m=(?<code>[\\w\\d]+))";
final String string = "https://my.matterport.com/show/?m=kiVrPJ4GLGF&brand=0&ts=2\n"
+ "https://my.matterport.com/show/?m=8QLBuW5dxqB&brand=0&ts=3&help=1\n"
+ "https://my.matterport.com/show/?m=vycyVs9Xe9W";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}