use strict;
my $str = 'https://my.matterport.com/show/?m=kiVrPJ4GLGF&brand=0&ts=2
https://my.matterport.com/show/?m=8QLBuW5dxqB&brand=0&ts=3&help=1
https://my.matterport.com/show/?m=vycyVs9Xe9W';
my $regex = qr/https?:\/\/my\.matterport\.com\/show\/\??(m=(?<code>[\w\d]+))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}