// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)((http(s)?[:\/\/]{1,}))?([a-z0-9\-]{1,}[.])([a-z0-9\-]{1,}[.])?([a-z]{2,3})(.{1,})?").unwrap();
let string = "http://example.com
http://subdom.example.com
http://example.uk
https://example.com
https://subdom.example.com
https://example.uk
http://example.com/?query=butt
http://subdom.example.com/?query=butt
http://example.uk/?query=butt
https://example.com/?query=butt
https://subdom.example.com/?query=butt
https://example.uk/?query=butr
tasdfa .ss";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}