re = /((http(s)?[:\/\/]{1,}))?([a-z0-9\-]{1,}[.])([a-z0-9\-]{1,}[.])?([a-z]{2,3})(.{1,})?/i
str = 'http://example.com
http://subdom.example.com
http://example.uk
https://example.com
https://subdom.example.com
https://example.uk
http://example.com/?query=butt
http://subdom.example.com/?query=butt
http://example.uk/?query=butt
https://example.com/?query=butt
https://subdom.example.com/?query=butt
https://example.uk/?query=butr
tasdfa .ss'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end