using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((http(s)?[:\/\/]{1,}))?([a-z0-9\-]{1,}[.])([a-z0-9\-]{1,}[.])?([a-z]{2,3})(.{1,})?";
string input = @"http://example.com
http://subdom.example.com
http://example.uk
https://example.com
https://subdom.example.com
https://example.uk
http://example.com/?query=butt
http://subdom.example.com/?query=butt
http://example.uk/?query=butt
https://example.com/?query=butt
https://subdom.example.com/?query=butt
https://example.uk/?query=butr
tasdfa .ss";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}