#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)((http(s)?[:\/\/]{1,}))?([a-z0-9\-]{1,}[.])([a-z0-9\-]{1,}[.])?([a-z]{2,3})(.{1,})?"
Local $sString = "http://example.com" & @CRLF & _
"" & @CRLF & _
"http://subdom.example.com" & @CRLF & _
"" & @CRLF & _
"http://example.uk" & @CRLF & _
"" & @CRLF & _
"https://example.com" & @CRLF & _
"" & @CRLF & _
"https://subdom.example.com" & @CRLF & _
"" & @CRLF & _
"https://example.uk" & @CRLF & _
"" & @CRLF & _
"http://example.com/?query=butt" & @CRLF & _
"" & @CRLF & _
"http://subdom.example.com/?query=butt" & @CRLF & _
"" & @CRLF & _
"http://example.uk/?query=butt" & @CRLF & _
"" & @CRLF & _
"https://example.com/?query=butt" & @CRLF & _
"" & @CRLF & _
"https://subdom.example.com/?query=butt" & @CRLF & _
"" & @CRLF & _
"https://example.uk/?query=butr" & @CRLF & _
"" & @CRLF & _
"tasdfa .ss"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")