re = /\( MI - [OF] - [0-9]* \)/m
str = '( MI - O - 30157 )
( MI - O - 30157Z )
( MI - O - 301576 )
( MI - F - 20157 )
(asd)
( asfdg )
( MI - A - 235 ) '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end