#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\( MI - [OF] - [0-9]* \)"
Local $sString = "( MI - O - 30157 )" & @CRLF & _
"( MI - O - 30157Z )" & @CRLF & _
"( MI - O - 301576 )" & @CRLF & _
"( MI - F - 20157 )" & @CRLF & _
"(asd)" & @CRLF & _
"( asfdg )" & @CRLF & _
"( MI - A - 235 ) "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")