const regex = new RegExp('\\( MI - [OF] - [0-9]* \\)', 'gm')
const str = `( MI - O - 30157 )
( MI - O - 30157Z )
( MI - O - 301576 )
( MI - F - 20157 )
(asd)
( asfdg )
( MI - A - 235 ) `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}