import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\( MI - [OF] - [0-9]* \\)";
final String string = "( MI - O - 30157 )\n"
+ "( MI - O - 30157Z )\n"
+ "( MI - O - 301576 )\n"
+ "( MI - F - 20157 )\n"
+ "(asd)\n"
+ "( asfdg )\n"
+ "( MI - A - 235 ) ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}