import Foundation
let pattern = #"^(?<wrappers>(?:[[:alpha:]][[:alnum:]]+://)*)(?<root>(?:[[:alpha:]]:/|/)?)(?<path>(?:[[:print:]]*))$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"vfs://D:/really/long/path/0.0.1/.././.secret/hide/out.sh"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}