using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<wrappers>(?:[[:alpha:]][[:alnum:]]+://)*)(?<root>(?:[[:alpha:]]:/|/)?)(?<path>(?:[[:print:]]*))$";
string input = @"vfs://D:/really/long/path/0.0.1/.././.secret/hide/out.sh";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}