const regex = /^(?<wrappers>(?:[[:alpha:]][[:alnum:]]+://)*)(?<root>(?:[[:alpha:]]:/|/)?)(?<path>(?:[[:print:]]*))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<wrappers>(?:[[:alpha:]][[:alnum:]]+:\/\/)*)(?<root>(?:[[:alpha:]]:\/|\/)?)(?<path>(?:[[:print:]]*))$', '')
const str = `vfs://D:/really/long/path/0.0.1/.././.secret/hide/out.sh`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}