re = /^(?<wrappers>(?:[[:alpha:]][[:alnum:]]+:\/\/)*)(?<root>(?:[[:alpha:]]:\/|\/)?)(?<path>(?:[[:print:]]*))$/
str = 'vfs://D:/really/long/path/0.0.1/.././.secret/hide/out.sh'
# Print the match result
str.match(re) do |match|
puts match.to_s
end